Computer and Technical Requirements

In order to effectively participate in the program, Fellows will need to meet the minimum technological standards.

  • The latest version of Google Chrome is required for Brightspace use. Additionally, a high-speed internet connection is recommended (at least 5Mbs (mega-bits-per-second) connection speed).

The learning platform is offered via Desire to Learn, via the Brightspace environment. Within this environment Fellows can visualize and interact with PowerPoint and other programs via a variety of devices such the purchase of outside programs is not warranted. Information related to accessing the Fellowship via variant devices will be explained during the orientation module.